<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":4,"applicationTime":428,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81929903-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>BuckeyeGrove.com  -  Young could be next Bosa, or better</title>
<meta content='BuckeyeGrove.com  -  Young could be next Bosa, or better' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-bd8e0400049933d7d82b6800a27663d3f82104735ca93ffa4c021e578eb2a73b.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="2JhVEiKZtH4+vxwX9JfZRqE+EUjq/lQbKYub/aJeSXz7gRJ6HB48Wy9Ar9QNZdwilP8durew0FULYQGVfpqRbw==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://ohiostate.rivals.com/news/young-could-be-next-bosa-or-better' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/nobvwnw2bi8iwfgyicwc' property='og:image'>
<meta content='Chase Young was dominant in a scrimmage, so what can be expected from the sophomore in the 2018 regular season? ' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-04-16 09:00:00 -0500' property='article:published_time'>
<meta content='2018-04-16 09:00:02 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "ohiostate.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='ohiostate contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .ohiostate #programming > h1 {
      background-color: #b50c00 !important; } }
  .ohiostate > header .notification-link .count-container {
    background-color: #b50c00 !important; }
  .ohiostate > header .wrapper-container {
    background-color: #b50c00 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .ohiostate > header .wrapper-container {
        border-bottom: 5px solid #959495 !important; } }
  .ohiostate > header .invalid-email-banner {
    background-color: #b50c00;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .ohiostate > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .ohiostate > header .invalid-email-banner a:hover {
      color: #959495; }
  @media screen and (max-width: 767px) {
    .ohiostate > header .mobile-header {
      background-color: #959495 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .ohiostate > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .ohiostate > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .ohiostate > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .ohiostate > header .nav-row > ul,
    .ohiostate > header .third-nav {
      background-color: white !important; }
    .ohiostate > header .dropdown-toggle > i.fa {
      color: #b50c00 !important; } }
  .ohiostate > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #b50c00; }
  
  .site-primary-font-color {
    color: #b50c00; }
  
  .site-primary-background-color {
    background-color: #b50c00; }
  
  .site-secondary-font-color {
    color: #959495; }
  
  .site-secondary-background-color {
    background-color: #959495; }
  
  :root {
    --outbrain-primary-color: #b50c00;
    --outbrain-secondary-color: #959495; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Ohio State" class="school-header" href="//ohiostate.rivals.com"><img src="https://res-5.cloudinary.com/rivals/image/upload/db7dyyblnqmc4ftuibef" alt="Db7dyyblnqmc4ftuibef" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//ohiostate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;ohiostate&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//ohiostate.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;ohiostate&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733129,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Young could be next Bosa, or better"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='Young could be next Bosa, or better' name='twitter:title'>
<meta content='Chase Young was dominant in a scrimmage, so what can be expected from the sophomore in the 2018 regular season? ' name='twitter:description'>
<meta content='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/nobvwnw2bi8iwfgyicwc' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1914453,"title":"\r\nNFL Draft: Top picks from the Big Ten in the past five years","slug":"nfl-draft-top-picks-from-the-big-ten-in-the-past-five-years-1","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-04-16T08:16:35.138-05:00","summary":"We looks at the top picks from the Big Ten over the few years paying attention to when they were high school stars. ","deleted":false,"author_name":"Rivals.com","author_title":"Special To","permalink":"https://n.rivals.com/news/nfl-draft-top-picks-from-the-big-ten-in-the-past-five-years","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1914318,"title":"Skull Session: Spring Game weekend update","slug":"skull-session-spring-game-weekend-update","kind":"free","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-15T18:14:23.841-05:00","summary":"Rumblings from the big visitor weekend in Columbus as well as RCS Atlanta updates.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/skull-session-spring-game-weekend-update","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1914236,"title":"Buckeyes continue to raise the bar for Wilson","slug":"buckeyes-continue-to-raise-the-bar-for-wilson","kind":"premium","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-15T11:43:42.604-05:00","summary":"Rivals100 wide receiver Garrett Wilson didn&#x0027;t think Ohio State could top the last visit, but the Buckeyes might have.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/buckeyes-continue-to-raise-the-bar-for-wilson","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1914202,"title":"Photos: 2018 Spring Game","slug":"photos-2018-spring-game","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-04-15T09:18:08.984-05:00","summary":"The Buckeyes managed to be the storms on Saturday and got their annual spring game in. ","deleted":false,"author_name":"Scott Stuart","author_title":"Staff","permalink":"https://ohiostate.rivals.com/galleries/1660","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1914153,"title":"Victor shows progress coaching staff wanted","slug":"victor-shows-progress-coaching-staff-wanted","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T21:33:37.561-05:00","summary":"Binjimen Victor had quite the spring game on Saturday, setting him up for a big 2018 season.","deleted":false,"author_name":"Nick McWilliams","author_title":"Staff Writer","permalink":"https://ohiostate.rivals.com/news/victor-shows-progress-coaching-staff-wanted","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1914084,"title":"Hamilton talks Buckeye spring game","slug":"hamilton-talks-buckeye-spring-game","kind":"free","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-14T18:16:42.642-05:00","summary":"The Buckeyes saw a tight end prospect out of Memphis (Tenn.) come through for the spring game.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/hamilton-talks-buckeye-spring-game","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1914011,"title":"Plenty of positives but still more questions than answers","slug":"plenty-of-positives-but-still-more-questions-than-answers","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T14:38:59.626-05:00","summary":"The Ohio State spring game is in the books and there was a lot to like but many major questions remain unanswered. ","deleted":false,"author_name":"Kevin Noon","author_title":"Publisher","permalink":"https://ohiostate.rivals.com/news/plenty-of-positives-but-still-more-questions-than-answers","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1914002,"title":"Little clarity given in QB battle according to Meyer","slug":"little-clarity-given-in-qb-battle-according-to-meyer","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T14:13:07.393-05:00","summary":"The 2018 spring game for Ohio State brought little clarity to the quarterback battle, according to Urban Meyer.","deleted":false,"author_name":"Nick McWilliams","author_title":"Staff Writer","permalink":"https://ohiostate.rivals.com/news/little-clarity-given-in-qb-battle-according-to-meyer","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913845,"title":"The Hickman Impact","slug":"the-hickman-impact","kind":"premium","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-13T20:20:51.751-05:00","summary":"Ohio State landed its first defensive prospect of the 2019 class on Friday. Just what are the Buckeyes getting?","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/the-hickman-impact","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913843,"title":"Buckeyes land four-star safety","slug":"buckeyes-land-four-star-safety-1","kind":"free","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-13T19:59:24.877-05:00","summary":"Ohio State&#x0027;s big recruiting weekend is off to a bang with a four-star commitment.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/buckeyes-land-four-star-safety-1","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913736,"title":"Big visits on tap for Spring Game weekend","slug":"big-visits-on-tap-for-spring-game-weekend","kind":"premium","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-13T13:21:06.261-05:00","summary":"Ohio State will see some of its top targets hit campus this weekend, could commitments be coming?","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/big-visits-on-tap-for-spring-game-weekend","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913640,"title":"Spring Game moved to 11:45 a.m.","slug":"spring-game-moved-to-11-45-a-m-","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-13T09:29:57.191-05:00","summary":"Ohio State&#x0027;s spring game is still on but it will be a little earlier on Saturday as it has been moved up two hours. ","deleted":false,"author_name":"Kevin Noon","author_title":"Publisher","permalink":"https://ohiostate.rivals.com/news/spring-game-moved-to-11-45-a-m-","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913567,"title":"Teague grows prior to freshman season","slug":"teague-grows-prior-to-freshman-season","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-13T07:00:00.000-05:00","summary":"With a veteran running back room, Ohio State back kMaster Teague grows prior to the start of his freshman season. ","deleted":false,"author_name":"Colin Gay","author_title":"Staff Writer","permalink":"https://ohiostate.rivals.com/news/teague-grows-prior-to-freshman-season","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913479,"title":"2019 Big Board: Safeties","slug":"2019-big-board-safeties","kind":"premium","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-12T16:09:53.748-05:00","summary":"Ohio State is in on some of the nation&#x0027;s top safety prospects. We&#x0027;ve put together our Big Board for the position.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/2019-big-board-safeties","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913448,"title":"The search for grad transfer(s) continues","slug":"the-search-for-grad-transfer-s-continues","kind":"premium","site_id":105,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-12T14:41:30.728-05:00","summary":"Chris Holtmann and the Buckeyes are still on the look out for an immediate impact player or two by way of grad transfer.","deleted":false,"author_name":"Kevin Noon","author_title":"Publisher","permalink":"https://ohiostate.rivals.com/news/the-search-for-grad-transfer-s-continues","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913412,"title":"One visit down and one coming up for local QB","slug":"one-visit-down-and-one-coming-up-for-local-qb","kind":"free","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-12T13:06:25.791-05:00","summary":"State champion quarterback Demeatric Crenshaw checked out Ohio State recently and will visit an ACC program next.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/one-visit-down-and-one-coming-up-for-local-qb","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913162,"title":"Four-star WR John Dunmore raves about Big Ten trip","slug":"four-star-wr-john-dunmore-raves-about-big-ten-trip","kind":"premium","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-11T16:25:46.138-05:00","summary":"The Buckeyes had one of the top receivers in the country on campus recently and he left with a strong impression. ","deleted":false,"author_name":"Adam Gorney","author_title":"Rivals.com","permalink":"https://n.rivals.com/news/four-star-wr-john-dunmore-raves-about-big-10-trip","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913045,"title":"Buckeyes continue to impress star linebacker recruit","slug":"buckeyes-continue-to-impress-star-linebacker-recruit","kind":"premium","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-04-11T14:38:16.233-05:00","summary":"After a third visit this past week, Ohio State continues to impress one of its top linebacker targets.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.rivals.com/news/buckeyes-continue-to-impress-star-linebacker-recruit","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1913010,"title":"Meyer updates position battles","slug":"meyer-updates-position-battles","kind":"free","site_id":105,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-11T13:19:53.403-05:00","summary":"Urban Meyer updated several key position battles as the spring game is rapidly approaching. ","deleted":false,"author_name":"Kevin Noon","author_title":"Publisher","permalink":"https://ohiostate.rivals.com/news/meyer-updates-position-battles","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1912778,"title":"Holtmann helps continue Ohio State rebuild ","slug":"holtmann-helps-continue-ohio-state-rebuild","kind":"premium","site_id":105,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-11T07:00:00.000-05:00","summary":"Ohio State head coach Chris Holtmann prepares for the 2018-19 season without Keita Bates-Diop and Jae&#x0027;Sean Tate ","deleted":false,"author_name":"Colin Gay","author_title":"Staff Writer","permalink":"https://ohiostate.rivals.com/news/holtmann-helps-continue-ohio-state-rebuild","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1912671,"title":"Notebook: Big QB target sets OV","slug":"notebook-big-qb-target-sets-ov","kind":"premium","site_id":105,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-04-10T16:33:54.301-05:00","summary":"The latest on Ohio State quarterback recruiting including news on when a top target will make his official visit.","deleted":false,"author_name":"Marc Givler","author_title":"Recruiting Analyst","permalink":"https://ohiostate.forums.rivals.com/threads/notebook-qb-target-sets-ov.75842/","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]},{"id":1912664,"title":"Holtmann begins building for the future","slug":"holtmann-begins-building-for-the-future","kind":"free","site_id":105,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-10T16:24:40.290-05:00","summary":"Ohio State head coach Chris Holtmann looks forward as his program lands two more players. ","deleted":false,"author_name":"Colin Gay","author_title":"Staff Writer","permalink":"https://ohiostate.rivals.com/news/holtmann-begins-building-for-the-future","site_name":"BuckeyeGrove.com","type":"Content","programming":[],"associated_links":[{"id":522,"url":"https://ohiostate.forums.rivals.com/forums/the-horseshoe-lounge.14/","display_text":"The Horseshoe Lounge","content_id":null,"created_at":"2017-02-15T09:06:19.024-06:00","updated_at":"2017-02-15T09:06:19.024-06:00","setting_id":130,"ordinality":1},{"id":523,"url":"https://ohiostate.rivals.com/commitments/football/2018","display_text":"2018 Commit List","content_id":null,"created_at":"2017-02-15T09:06:19.028-06:00","updated_at":"2017-02-15T09:06:19.028-06:00","setting_id":130,"ordinality":2}]}], nil, 105, nil, true); subdomain = &#x0027;ohiostate&#x0027;; aolPlayerId = &#x0027;59643c1e8c08e021702e77a1&#x0027;; aolCompanyId = &#x0027;595e59c62a30cb7ee3e53928&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #b50c00'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":323,"image_id":2161490,"url":"https://ohiostate.rivals.com/sign_up?promo_code=OSUSpring","position":1,"site_id":105,"created_at":"2018-04-03T15:28:18.634-05:00","updated_at":"2018-04-03T15:28:18.634-05:00","image_url":"https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/ltro4ppiovwtir5rdj2r"}' class='ad-one'></rv-custom-ad>

<rv-homepage-forums ad-referer='https://ohiostate.rivals.com/news/young-could-be-next-bosa-or-better' background-color='#b50c00' base-api-url='https://ohiostate.forums.rivals.com/' homepage='false' message-board-url='ohiostate.forums.rivals.com' pub-ad='null' size='size' space-id='2022733129' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://ohiostate.rivals.com/news/young-could-be-next-bosa-or-better/printable' site-name='BuckeyeGrove.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-04-16 09:00:00 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1914457/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Young could be next Bosa, or better</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Nick McWilliams
&bull;
</span>
<span class='type-sm'>BuckeyeGrove.com</span>
<div class='type-sm'>
<a href='//twitter.com/NickM_OSU' target='_blank'>@NickM_OSU</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Staff Writer</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/NickM_OSU'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>Chase Young looked unblocked at times in the spring game, even though he was just getting around the offensive line that easily.</h3>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/nobvwnw2bi8iwfgyicwc)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/nobvwnw2bi8iwfgyicwc" alt="Nobvwnw2bi8iwfgyicwc" />
</div>
<figcaption class='image-caption'>Chase Young thought he had around six sacks on Saturday</figcaption>
<div class='image-credit'>USA Today Sports</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>COLUMBUS, Ohio - Urban Meyer's heart was likely racing when Chase Young first bolted around offensive tackle Thayer Munford. While at first it might have been due to the freak athleticism Young put on display, he likely soon realized Dwayne Haskins might become part of the turf if Young had his way.</p><p>Iinstead, Meyer yelled out to Young, pleading with him "don't even tackle" as he grabbed Haskins on his shoulder pads. Young obliged, instead holding on until the whistle blew. That kind of scene was fairly common Saturday.</p><p>Credited with one sack all day, Young was a little perturbed over that number. He felt his number should've been more like six. After the game, Young was sure to let Haskins know how many times he wanted to plant his quarterback into the Ohio Stadium ground.</p><p>"I told Dwayne if we could tackle, I would've hit him three times today and the ball would've popped out," Young said. "He knows that. I let him throw. I told him before the game 'I'm gonna be on your butt.'"</p><p>It was almost embarrassing how many times Young found his way to the backfield, simply blowing by a lineman or pulling off any number of nifty moves. It might have looked like Munford's feet were standing still, but it's important to remember what exactly he was going up against.</p><p>Young is now officially listed at 6-foot-5 and 265 pounds, a near identical body to outgoing defensive ends Jalyn Holmes and Sam Hubbard. But while Holmes was the stronger one and Hubbard the faster, it seems Young has them both beat in their respective categories. </p><p>There was plenty to like from his game last year, but 2018 has clearly been a huge step in the right direction in terms of development for him. </p><p>"I think I progressed a lot," Young said. "It's more looking at Nick Bosa. He's got very good hips. I think I look at Nick a lot. He's one of the best to do it."</p><p>Young might have passed Bosa in physicality this off-season, although he was not far off last year. There's something to be said about a player who's only a sophomore but already looks like the most physically imposing player on the field.</p><p>Defensive coordinator Greg Schiano sees the same thing in Young's long yet solid frame.</p><p>"Chase is a physically imposing guy with his length, so I think that’s an advantage he has,” Schiano said. “And I think he’s getting better at the technique that coach (Larry Johnson) teaches. I think that’s going to be a lethal combination."</p><p>That "lethal" combination for Young is somewhat like the dangerous combination of camouflage and a shoulder cannon of the fictional character he gets his nickname from, Predator. </p><p>They have similar hairstyles, but the difference in this comparison is, Young doesn't need to disappear to bring terror to his opponents. He just needs to line up across from there, eyes glaring forward, ready to pounce. </p><p>Who knows what kind of sack totals Young can have this season, given that Johnson wants to see 50-60 sacks from both the sophomore and Bosa. Who gets the double-team when they're both on the field?</p><p>The loss of three defensive ends to the NFL draft was a bitter pill to swallow for fans, but the reintroduction to their successors quickly takes away all gloom. Young predicted 10.5 sacks in 2018 after the Cotton Bowl, which should be easily obtainable if he plays on a similar level in the regular season.</p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://ohiostate.rivals.com/news/young-could-be-next-bosa-or-better/printable' site-name='BuckeyeGrove.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":2,"footballYear":2019,"basketballYear":2018},{"active":true,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":105,"legacy_id":917,"name":"BuckeyeGrove.com","friendly_name":"Ohio State","annual_discount":null,"subdomain":"ohiostate","primary_color":"b50c00","secondary_color":"959495","font_color":"ffffff","short_name":"ohiostate","maple_ncaaf_team_id":33,"maple_ncaaf_endpoint":"ncaaf/teams/oob","maple_ncaab_team_id":443,"maple_ncaab_endpoint":"ncaab/teams/oad","maple_college_id":33,"google_analytics_id":"UA-81929903-1"}' twitter-feed='{"id":105,"site_id":105,"handle":null,"list_name":null,"created_at":"2016-02-01T12:25:16.311-06:00","updated_at":"2016-02-01T12:25:16.311-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://ohiostate.rivals.com/news/young-could-be-next-bosa-or-better/printable' site-name='BuckeyeGrove.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733129', 'https://ohiostate.rivals.com/news/young-could-be-next-bosa-or-better');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Young could be next Bosa, or better";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":323,"image_id":2161490,"url":"https://ohiostate.rivals.com/sign_up?promo_code=OSUSpring","position":1,"site_id":105,"created_at":"2018-04-03T15:28:18.634-05:00","updated_at":"2018-04-03T15:28:18.634-05:00","image_url":"https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/ltro4ppiovwtir5rdj2r"}' class='ad-one'></rv-custom-ad>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://ohiostate.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733129",
    c7: "https://ohiostate.rivals.com/news/young-could-be-next-bosa-or-better"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fohiostate.rivals.com%2Fnews%2Fyoung-could-be-next-bosa-or-better&c5=2022733129&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
